Facebook Login Failed (Resolved)

  • Today after a crash I was logged out of FB in ABE.
    Happened before, NP I thought, however I get a “Facebook login failed” error everytime I press login.

    – I am using a separate FB account for games, with about 120 ABE users on it. Possible cause since they are so many?
    – When logged out of Rovio account (birds lvl 1) the FB login is succesful and I see all friends!
    – Login with my real FB account works (2 ABE users)
    – Complete wipe + reinstalls of FB and ABE did not fix it
    – Restarts of phone did nog fix anything
    – I am lvl 41 in Cave 13

    Any ideas of what may be wrong?
    Maybe the game can’t handle drawing the entire map with many friends on it?

    Perhaps tomorrow I’ll try cleaning the FB account, keeping the higher Bird level people.

    PS I sent Rovio support a ticket, but alsof asking here since ABN is usually much faster

Viewing 16 replies - 1 through 16 (of 16 total)
  • Replies
  • MVNLA2
    @mvnla2

    @henjovr — You didn’t say what platform you play on. I play on iPad with IOS 7. I’ve had problems with the Facebook login (not recently). I would try the standard hoodoo-voodoo: Log out of FB from within Epic; log out of FB from FB. Hard-close all apps running in the background. Do a hard shutdown of your device. Wait 30 sec. Restart device and restart Epic. Log into FB from Epic; then login from FB (or is it the opposite order?). Good luck!

    Bossk
    @henjovr

    Running in Android 4.4.4
    Tried all combinations like you posted multiple times, including wiping caches etc..
    No result.

    abirds954
    @abirds954

    @henjovr Any chance you can log into Facebook on the Web? Maybe the permissions to allow the game to access your made-for-the-game account are turned off?

    SmutjeBird
    @adryan

    A mi también me pasa lo mismo, pero yo pienso que ha sido error de los programadores del juego en la última actualización…

    Abe Val
    @abe-val

    I have exactly the same problem. On Nexus 4 (Android 4.4 & 5.0).

    My normal FB account doesn’t work anymore, and the game have the permissions

    Doc Mayank
    @doc-mayank

    Having the same problem. On IOS 8.
    Started this afternoon… Weird

    abirds954
    @abirds954

    @doc-mayank Go to settings and the Facebook app, see if it needs you to re-login. Happened to me when I upgraded to iOS8.

    Doc Mayank
    @doc-mayank

    @abirds954
    Thank you, this worked! :)

    Bossk
    @henjovr

    For me the problem was gone after a few days.
    Suddenly the login was succesful again… I can’t explain it, but am happy that it works again.

    Jon
    @epicjon

    I’m having the same problem. It constantly says login failed. I have been regularly receiving requests for friendship gates and friendship essence, although the only person on my list is piggy mccool, and of course I can’t ask for essence because I can’t connect. I tried the whole uninstall – reinstall and logging out of each and all that garbage. It’s getting really frustrating.

    TimeWalker
    @timewalker

    Well, I just have this problem too. I’m on Android 4.4.2 and no matter what I do, I always get “Facebook Login failed”. I tried it with and without Facebook app, both not working. Reinstalling Epic, still no dice. The only time Facebook login works is when I’m logged off my Rovio account.

    As I only see solutions for the iOS version, did anybody manage to fix it on Android?

    abirds954
    @abirds954

    @timewalker I haven’t touched Android in years, so I’m spitballing here:

    Is there a permissions page buried in settings that shows what apps can read what?
    Are you able to access the FB app on your phone?
    Try logging in to a Web FB session and see if there are settings only viewable on a computer?

    TimeWalker
    @timewalker

    I do have App Ops but the only permissions I can activate/deactivate are Location, Volume and Keep awake.
    I removed the Facebook app as I don’t use it and only had it to test Facebook login.
    I don’t see any other special setings for apps on my PC or mobile phone. I tried deactivating app login and removing Epic but it still doesn’t work.
    As a side note, Transformers seems to login fine.

    Thanks for helping me though.

    Jon
    @epicjon

    Ok, so I fixed the problem, but I’m not 100% sure how. Following a support ticket from Rovio I tried a bunch of stuff till it worked. Here is what they sent me and then I sent them. Perhaps it’ll help you. Still took me an hour of messing around to get it to work.

    Hey Jonathan,

    and thanks for contacting us!

    We’re sorry to hear you’re having trouble with Angry Birds Epic. You could first try these steps to fix the issue, another customer with the exact same problem reported that this worked:

    1) Sign out of your Rovio Account
    2) Disconnect Epic from Facebook
    3) Sign in to your Rovio Account
    4) If the it now looks like you’re connected to FB, disconnect
    5) Exit the account settings screen
    6) Enter the menu again to connect to Facebook again

    Hope this helps! If you keep experiencing trouble, please get back to us with details on your device model and OS version.

    Best regards,

    Jutta
    Rovio Support Team

    I’m confused, step 2 says to disconnect epic from Facebook. How is this possible if the problem is that I cannot connect to Facebook? Am I missing something?

    After fooling around with various combinations of what you’ve suggested I am no connected to Facebook. A couple of times I’d connect, then exit account settings and come back in and it would say that I was, in fact, not connected. Then if I tried to connect it’d bring up the Facebook app and go through two-three quick screens and restart AB Epic to no avail.

    Eventually, I disconnected from Rovio. Then I connected to Facebook successfully. I then left account settings (no reason really, just fooling around with different combinations of what you’d suggested), returned and connected to Rovio. I have since (15 minutes or so) been successfully connected to both.

    So thank you for providing some ideas to consider in order to connect, but the steps you suggested did not work for me. It took many tries and a random combination relative to your steps to get it to work for me. The success in connecting is definitely thanks to you, Jutta, but it took a lot of persistence. So thank you! I am not going to mark this issue as resolved just yet, in case the issue returns. I will be sure to mark it as resolved after a few days of consistent service.

    Here is my device model and OS version so as to hopefully help your developers:

    Model – MF260LL/A (iPhone 4s)
    Version – 8.1.1 (12B435)

    Thank you!

    TimeWalker
    @timewalker

    Thanks for the tip! I finally managed to make it work by doing this:

    1. Go to your nest and then at the login tab at the totem (where you can login Rovio, Facebook, etc.)
    2. Log out from your Rovio account
    3. Log in to Facebook
    4. Log in to Rovio account
    NOTE: Don’t switch to any other tab or close the window, else it brings you back to the map and you have to do it again.
    5. Facebook should automatically log out. Relog again (this time Facebook login pops up).

    With that, I successfully was able to login to Rovio and Facebook and it seems to stay that way.

    Jon
    @epicjon

    Yeah, mine has stayed logged in ever since fortunately. It makes things so much more fun.

Viewing 16 replies - 1 through 16 (of 16 total)
  • The topic ‘Facebook Login Failed (Resolved)’ is closed to new replies.