Can't open space HD

Home Forums General Discussions Forum Can't open space HD

  • I don’t know what changed or if I am doing something wrong, when I try to open Space it forces me to install Battle Bay. No matter what I select it puts me right into iTunes App Store to download this game (that I don’t want!).

    Even tapping the right pointing arrow in the middle (like all the other apps open) or anything on the start screen it goes straight to the App Store.
    I tried to close the advertisement to load Battle Bay so,I can get into “Space”, but can’t find any “X” to close it.

    Basically I am stuck at the start screen for space and being forced to download a game I don’t want (Battle Bay) and still can’t get inside the game I want to play. I have been playing space HD “paid version years. I have never had this happen before.

    @admins do any of you or anyone else ran into this issue?
    I am in IPad2 air. Running the current IOS.
    Am I just missing something?
    All,I want to do is play some levels in Space to improve my prior scores.
    This just might be a “Duh moment, “user error” on my part.
    Help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Replies
  • Ladybird
    @diannas

    @admins
    Ok, Nevermind! User error!
    As soon as I posted above, I found a “workaround” to get into the Space app. I knew I should have tried harder, but it shouldn’t be hard to open an app…… I clicked on the arrow button at the lower right corner this brought up the space App information icons that popped up in front of the Battle Bay (hook to download). With the space info icon open in front, I then selected the right arrow and got into the space program!

    But it shouldn’t be this tricky to get into a App you have paid for and been using for years. Rovio has gotten so hungry to get one to download more games that cost money to play (like in coins and power ups). There is too many money type things they dangle in front of players, it is getting old! I thought I paid for a commercial free program?
    Ok, off my “soap box”.
    I am happy I figured out how to access the space app.

    Bird Leader
    @birdleader

    Thanks for following up @diannas. I was about to email rovio. Will close this now.

Home Forums General Discussions Forum Can't open space HD

Viewing 2 replies - 1 through 2 (of 2 total)

The topic ‘Can't open space HD’ is closed to new replies.