My Red's Mighty Feathers disappeared - bug or what?
  • Strange thing happened to me today. I finished all levels in RMF yesterday and this afternoon I wanted to improve some of my scores. When I opened game all my progress in episode were lost. I "hard closed" iPad and turn it on again, sign on my Rovio account and my scores were back. Is that possible bug or what can it be? Anyone has explanation?
  • Glitches do happen on occasion. Be happy you got your scores back.

    As with anything electronic when it starts going haywire is just what you did... turn it off, wait a moment, then turn it back on.
  • No No No No! That is way incorrect. The correct procedure is to scream bloody murder and slam things all over your house. Then you go online and proclaim to the world that Rovio is the worst company in the world, it is somehow ABN's fault also, the US and Finland governments are involved and rant on Reddit and any other forums you can find that you are going to sue!
    When it comes back the next time you turn it on you don't say nuthin' to nobody.

    THAT'S the way the internet works.
  • @78RPM The power of the internet is too massive :P
  • I had the exact opposite happen. Just finished the 15 levels of RMF (had entered 14 of the 15 scores on ABN), then logged into my Rovio account (I was logged out after the iOS 7 update). All 15 scores disappeared (along with the golden egg I had achieved for 3-starring all 15 levels). Wrote Rovio but don't really expect they can help me. Looks like RMF level 23 was all that was affected as the 3 non-scoring levels I completed a while back are still there.
  • @ABeggerToo - Did they come back? The last time I opened the game my Red Feathers scores were gone but when I backed out and went in again they were there. This was on Android so IOS7 wasn't involved.
  • I'm playing on a Nexus 7 with Android 4.2. I finished all 15 levels of RMF 23 last week. Tonight I went back to AB and tried to access my Rovio account. It hung (dots going back and forth for a long time.) Quit and tried again, it told me I had logged out of my Rovio account. That's when I noticed my scores for RMF 23 were gone. RMF 24 scores were okay. After a while, I tried again, Rovio account hung, scores still missing. I rebooted the Nexus, still no change. I really hope I get my RMF 23 scores back!
  • This problem is also happen on my phone, it just showing Red with the moving dots, although my phone has an internet connection.
  • Yep I'm in the same boat. The internet connection that links my devices is not connecting and so I have no scores at all, on RMF, except on my iphone at level 23-1. This is very very bad! How do we play when we don't have wifi/3g? Answers please Rovio.
  • There might be a problem with the "Rovio's server", I can't even access Rovio account and the Toons channel.
  • I'm currently working on an email to send to Rovio with a few suggestions. I'll likely send it off within the next few days. (We feel a little guilty since we've been bombarding them with questions about not-yet-published-here info that we've come across, so it's only fair to let them breathe a little.)
  • Hm. I've been getting logged out of my Rovio account fairly frequently lately, both before and after upgrading to iOS 7. Until yesterday, not a biggie, but then I discovered one of my RMF scores was lost. I distinctly remember getting that score because I was quite happy to break 80k. My score had reverted to my previous 78k score.
  • Reference my previous message - tonight I was able to log in to my Rovio account, but then it failed to communicate and I got a red circle with a slash through it. Perhaps Rovio is getting things repaired. It would be nice if they would let us know, and tell us if our scores will be fixed.
  • Same thing happen to me yesterday while I was out using cellular, I wasn't able to connect to Rovio's server and my RMF score was 0, while stars on Egg Defender were there. After I arrived home I connected to my account using wi fi connection this time and scores were back again.
  • This has happened twice to me over the last couple of days. 1st time nearly resulted in a major breakdown when I saw all my scores were gone. Quickly checked all the other levels to find that they were ok,it was just red feather. Then a message declared I had been logged out of Rovio account. FYI,I hadn't lost internet connection at any point. I logged back into Rovio and voila all my scores were back!!! Happened again yesterday but more worrying is it took about an hour to connect back up with Rovio. The birdie to www image just slowly trickled along. Both these times there's been absolutely nothing wrong with Internet connection. I play on iPhone 4S and haven't installed iOS7 yet.........waiting on the inevitable issues to be ironed out first ;)
  • Rovio is working on their servers as we speak.
  • My conclusion: The new update of Red's Mighty Feather is great but it has so many bugs : first is the 30th golden egg doesn't pop up, second is the 8th golden egg is no longer obtainable and now with the losing scores and unable to sign in to Rovio account issue.
    Before the update I can play without internet connection and my progress is fully saved, but now I will be signed out immediatelty if I don't have wifi/3g. Hopefully Rovio will fix all of these bugs soon.
  • Great! Thanks for the update @amslimfordy
  • My scores are back! I successfully connected with Rovio and my RMF scores were back. However, yesterday I improved my score on two levels of a different episode, and those scores were wiped out. So it appears that scores will be reset from the time of the failure, not merged to incorporate any new scores since then.
  • @78RPM thanks for the best explanation of the internet I've ever read!
This discussion has been closed. Please check the new forum.
← All Discussions
Post in the New Forum!