Bought Mighty Eagle, But I Can't Use It
  • I'm using a samsung exhibit II 4G. I purchased the mighty eagle on Angry Birds Rio and I clicked on the Mighty Eagle icon in one of the levels and it still asked me to purchase it. Can you guys please helped me out. I wasted 99 cents on the Mighty Eagle, did I get ripped off? I received an email from Google in my Gmail account that I purchased it, but on angry birds rio I still get this message that says "The MIGHTY EAGLE, Buy Once, unlimited use! $0.99". I closed the angry birds rio app and reopened it. Used an app killer and reopened angry birds rio. Turned off my phone, and tured it back on and I still get that message that I have to pay for the mighty eagle. I don't know if this is a bug but you guys got to help me.
  • @Roger -- It's Christmas Eve, and I think most of the admins have the day off. You might try checking the bugs forum or sending an e-mail to the admins (About / Contact. Did you check any other AB games? You have to purchase it separately for ABO, Rio, and Seasons. Good Luck
  • @Roger There's not much we can do since we are neither the app developer nor associated with Google Play. However, I would recommend the following course of action: Try restarting your device (I know you already did, but it forces the app to start anew) and go through the process of trying to purchase the Mighty Eagle again. It's unlikely that you would be charged a second time (and if you did, you can very easily contact Google Play about the double-charge). If still unsuccessful, GPlay is the best group to contact, as they can probably remove the purchase from your account and you can try again.
This discussion has been closed. Please check the new forum.
← All Discussions
Post in the New Forum!