Purchased Path of the Jedi but can't Access It
  • Hi,

    I apologize if this has previously been discussed, but I did a cursory search and didn't find anything. On my Android device, I paid the $1.99 to purchase the Path of the Jedi levels, but I cannot access anything beyond the first level. Instead, I am again prompted to purchase it. When I try to again (just to see what happens), it takes me to the Google Play Store, which confirms I have purchased it. This problem happened before and after the recent Hoth update. Has anyone else had this problem, and if so, how do you resolve it? Unfortunately, it doesn't look like there's a way to refund your money for an in app purchase like this.

    Thanks in advance for your help.
  • You should contact Google Play. They can track whether or not you actually purchased the item.

    Have you tried using the "IAP Refresh" button on the front page of the app? Click on the gear in the bottom-left corner, then the shopping cart with little arrows around it.
  • I have a shopping cart, but it's in the middle of the screen (not under the gear). I had tried that, and when I go to the Path of the Jedi screen, it again prompts me to buy it, so it's definitely not recognizing my purchase.

    I'll contact Google Play. Thanks for your help.
This discussion has been closed. Please check the new forum.
← All Discussions
Post in the New Forum!