Bad Piggies Glitches & Bugs (Moved to the "New Forum"!) Page 3
  • I am happy to report that the new update for the PC solved the wifi problem. I updated and was able to activate the game permanently.
  • @brave1966: Yes it worked :D. After weeks of waiting, finally I can torture the pigs again! Btw I used 1280 x 600 resolution to activate and play the game, and the game runs fine :).
  • @DaBoid & @bluegie: Good deal! :D

    @AMslimfordy: The activation issues have been resolved. 1024x768 non-windowed mode still flickers as previously noted, 1024x768 windowed mode works fine. :)
  • @DaBoid @bluegie @brave1966 I appreciate the reports! YAY!
  • Thanks @AMslimfordy for all you do on the Nest! You've had a busy couple of weeks with the AA, ABS, ABSp and BP updates, plus the ABSW launch. I am glad to help however I can. :)

    As soon as I finish slaying some more Haunted Hogs and Imperial Swine, I'm back to buliding contraptions on BP. :)
  • upon installing the first update on my REGISTERED Bad Piggies (PC) it had the key icon wanting me to activate full version. Are all updates for this game gonna cost me more money????
  • @narcjoe You can use the same activation code from when you first purchased the game. There's no harm in that.
  • @narcjoe: Did you try reentering your registration key? This should be working now.
  • Can someone tell me where progress is saved when an Android phone does not have access to the SD card?

    I played many levels while my phone was tethered to my laptop (which makes the SD card unavailable to the phone), and now I can access that progress while I'm tethered to the computer, but not when my phone is untethered.
  • Yes, that tells where the progress is saved when the SD card is available. I can find that, and it has my progress from when I was not tethered (the phone has access to the SD card). That file does not contain the progress from when the SD card is not available. I know that this progress is saved, because whenever I tether with USB cable to a computer (does not matter which computer), Bad Piggies finds the progress that I've made while tethered (SD card not available).

    So, it's storing progress data in a secondary location when the SD card is not availble, but I can't find where.
  • I have Bad Piggies for IOS, I've updated to 1.1.0 without problem. I can buy mechanic pigs but I can't buy Field of Dreams. When I try to buy it, I receive a message that says "In-app purchase not enabled". I've checked the settings and all is correct. What can I do?
  • @Loupar: I'd contact Rovio Support; tell them what iDevice and iOS version you're running.
  • I've got an iPod Touch 3rd Gen 32 Gb and this problem happened both in 4.3.2 and 5.1.1 (I've updated recently because this error).
    Are there somebody with the same problem?
  • You should try restarting your device(s) and signing out/in to iTunes manually.
  • @AMslimfordy: I don't get the Tourist III achievement. I think it's because of the offline bug.
    Do you think I can make a backup, delete the app from my phone and then install it again and get only Tourist III while I'm online and then restore from my backup? Then I would still have Tourist III with my old scores, I think.
  • Ok is this normal?In sandbox mode I placed balloons everywhere on my contraption It hit the wall at the very top of the level and fall at great speed and when it hit the floor the machine burst and because I placed rockets to help me fly up faster when the machine fell the rockets burst into the rocks and it remained there.And one time I did the same like just now and flew up very fast until the pig passed trough the wall on top and it flew of screen and back down on top the rock ceiling.Very wierd I know, anyone had this problem or it is the part of the game?
  • I am back to write a silly mistake About gamecenter achievements ok once I placed a lot of things and it should be getting the someting achievement like complecks or something but I got it nothing happend.Same like some achievements just the SAME.
  • @Castrode When objects move too quickly, they can pass through solid walls and ground. This is part of the limitations of Box2D and other gaming emulators. Their impassible boundaries are only a pixel or two wide, and fast-moving objects can go faster than the check rate.
  • Running android jelly bean. Bought field of dreams from the Play store. When I click it, my only option says buy for $2.99. If I click the buy button, it tells me I already have it installed. From there I can click OK which starts to take me to the play store and then everything crashes. How can I fix this so I can use what I paid for?
  • Contact either Rovio or Google.
  • When ever i try to put the activation code in it says no response from sever plz help!
  • @Gamer123 Be sure you are connected to the Internet when entering the code.
  • I am when i try and if i wernt connected then i wouldet even be able to go on the internet in the first place
  • Have you tried restarting your computer?
  • I've been playing this all day with no problem, but after I shut down and then tried to open "Angry Birds" again there is an error window that says. " Failed to open data/shaders/GL2/2d-Sprite-Alpha-mashed-fx with Errno 2". Could anyone tell what this is and what to do about it.

    Thanks for your help.

  • TNT can make the pig and objects fly through walls and make springs stretched without going back to normal. A lot of games that I know have explosion problems like Minecraft. Is Rovio aware of this?
  • @bradman, maybe you should ask Rovio for explanation. I am also curious why that happens.
  • @AMslimfordy, why don't you talk to me any more?
  • I don't carry on casual conversation with hardly anyone on-site. Besides BL and Sal, there's maybe 3 people I chat with.
  • The Road Hogs update did not fix the problem I have with no GC achievements showing (well, OK there are still 2). I hard closed all apps on iPad, and turned power off and restarted. Then I completed one level in each of the first 3 episodes.
    There may also be a bug in the leaderboard for Road Hogs, since so far it only shows the score for the first level.
  • @AMslimfordy, I'm not talking about chatting, I'm talking about the question I asked above in this forum thread about the Bad Piggies achievement.
  • Didn't notice it. It's worth a try. It certainly can't hurt.
  • There was a minor Bad Piggies update today. Anything get changed or fixed?
  • I think it's compatibility with the GC LBs.
  • Do Road Hogs leaderboards on GC work for you? They've updated it so all levels are included, but only R1 is correct for me. The other levels either put wrong times or have no rating at all ("never played").
  • It will update as you set new times.
  • Will it post your lowest time ever, or just the lowest time since the update?
  • Lowest time since the update.
  • @mvnla2 and @amslimfordy I didn't update Bad Piggies after hearing people report about bug. What do you think if I update it now would it keep my current scores or I'll have to start all RH again?
  • You will keep your lowest times after the update, but apparently they will not be registered in GC. I would call that a bug.
  • It's definitely still buggy. I registered a time on GC on R4, but the next time I logged in to GC it was gone.
  • I wouldn't update it, hope they will fix GC leaderboard bug with update which would bring new levels, until new levels I really don't need any "fixing" that would make things go wrong
  • I can't see my rank for levels 5 and 6 although I finished both of them. Could it be an other GC glitch?
  • I have the PC version of Bad Piggies, and in that I did nearly all the levels of Ground Hog Day and unlocked the sandbox levels of that episode, but when I updated to 1.2.0 the stars for the Ground Hog Day levels were there, but the sandbox levels I had unlocked in the previous version had become locked, I tried to do the levels again hoping that it would unlock but to no avail, can you help me out? I already tried re-installing and restarting the game but nothing works. Any ideas?
  • @Zeemo Did Road Hogs levels are also locked like sandbox ? If yes, you need to enter the same activation code again which you have used in previous version's activation. This will unlock all the episodes including sandbox.
  • The new update is really bugged up. It crashes every time I use Everplay, and freezes up/crashes every once in a while at random.
  • Latest BPgs on IOS 1.4.x still has GC achievement bug. May have correct number of achievements earned, but still only shows 2.
  • @cosmo2503 @bradman in @slim's own words:
    This happens occasionally. It's an unfortunate side-effect of Box2D and similar programs.
This discussion has been closed. Please check the new forum.
← All Discussions
Post in the New Forum!