Bad Piggies Glitches & Bugs (Moved to the "New Forum"!) Page 2
  • @DaBoid : As @bluegie noted in his October 6 post, you'll need to be on a wired connection to play BP until Rovio releases an update.
  • I'm also running iOS 6 on my iPhone (though only 5.1.1 on my iPad since I must remain jailbroken to do videos for this site). No Adventurer.
  • Slim check the comment again i've updated it
  • same thing they said to me DaBoid, guess we have to wait on the update
  • They changed the "description" of the Adventurer and Discoverer achievement in Game Center.

    When the game came out, it said (as Little Brother Bird's screenshot proves):

    Adventurer: Discover 10 explorer remains in episode 1
    Discoverer: Discover 10 explorer remains in episode 2

    But now it sais:

    Adventurer: Discover 10 explorer remains
    Discoverer: Discover 20 explorer remains

    Nevertheless I don't have Adventurer although I have more than 10 skulls.
  • Thanks @Chriss. I'll try to update these later today.
  • I got to level 2-15 (iPhone 4, iOS6) and now when I play a level, including previously complete levels, Bad Piggies shuts down when I cross any finish line and takes me back to my iPhone icon screen. When I go back into bad piggies, it doesn't register that the level was completed. I have restarted my phone to try, and the only thing I can think of doing is deleting bad piggies and re-installing, but I don't want to risk losing my progress on the levels I've already completed.
  • I noticed the "discover X explorer remains" are pretty buggy (this is on iOS 5.1.1). I didn't get Adventurer at first even though I had over 10 remains discovered (some in episode 1, some in 2). Then after getting all the episode 1 remains, I got both Adventurer and Discoverer even though I had 3 remains left to get.

    And I have no idea how to get "Crash course", it never gives you enough rockets to do 6 at once (at least 6 of 1 type, mixing and matching doesn't seem to work).
  • I have Crash Cource But I miss the ?Discover 10 explorer remains, 20 while i have the 20 version
  • How do u get crash course? Do you put up red and blue rockets or just a certain colour? Also do u have to survive to get this achievement?
  • I really don't know I have it but I can't remember how to get it.
  • The GC bug for IOS 4 has not been fixed, as far as I can tell. Still saying I have 26 achievements, but only showing 1. Interestingly, Rovio answered my problem report from a month ago this morning (before I got update). They had nothing useful to say. Today I tried signing out of GC, closing all open apps, and turning iPad off and back on: still no achievements.
  • Bug: There are 20 skulls to gather before opening the Skull-Sandbox. I only had 10 out of 20 when it opened. I personally think that this is a bummer.
  • @BirdCeption the S-5 Sandbox opens at 10. This is the design.
  • With the new update:

    • Crash Course FIXED
    • Adventurer (slim): NOT FIXED
  • I confirm: Crash Course "fixed", but maybe it was never bugged. Maybe it only works with 6 rockets of the same color.
    Adventurer not fixed :-(
    And also the offline achievement bug seems to be not fixed yet. I'm sure I should have 100000 miles, but still no Tourist III achievement.

    @amslimfordy: You wanted to update the Discoverer and Adventurer achievement (see my post above from October 15th).
  • Sorry, I have to correct myself: Adventurer is fixed. It just popped up, but only after a while of playing.
  • Update: My Bad Piggies won't authenticate over wifi (PC). I've been waiting for the update and hope to have it soon. Yesterday we got AT&T UVerse and I once again tried Bad Piggies. Same thing. It works great wired in to the router, but once I disconnect from the router it goes back to the demo version.
  • @billymt @Chriss It seems Adventurer is fixed. Obtaining 1 more skull triggered it for me.
  • @AMslimfordy sorry for the delay in my response. Yes, Adventurer and Discoverer were correct for me.
    I was also able to get Crash Course. You have to use 6 of the same rockets. I did it on the Field of Dreams level with 6 blue rockets. Then when you back out to the main screen, it appears.
  • @DaBoid: So that means I dun need to update the PC version since I can't play it anywayz. I hope they will fix the wireless => inactivation issue soon...
  • @DaBoid @bluegie I'm not sure why you were expecting the issue to be fixed without an update?
  • Adventurer achievement is repaired: just get one new skull and you get it.
  • @AMslimfordy didn't get achievement, not even after getting my 21st skull :s
  • "I'm not sure why you were expecting the issue to be fixed without an update?"

    @AMslimfordy because the first problem I experienced was a "z" in the activation code. I could not enter "z" with my keyboard. Rovio support told me to enter "z" in lower case, which did not work. I tried copying and pasting from Notepad, which simiarly did not work. Then, they sent me a new activation code, without a "z", which did not work.

    Next they asked for details of my Windows version, IE version, etc. I sent that to them, and being an IT professional, I knew where to look and sent them exactly what they needed. They replied thanking me and telling me I had really helped them narrow down the issue. They asked if I had a current anti-virus, etc., and I replied yes, anti-virus was current and all Windows 7 patches were updated. My computer is well-protected with an enterprise-strength security package.

    Finally, after a week of back-and-forth, they told me to try hard wiring into my router. I did, and it worked, but when I went back to wifi, authentication failed. That's when they told me to wait for an update. I'm still waiting.

    I had to hard-wire into my router to register my new Uverse anyway, so after having completed that task, I tried Bad Piggies again with the same failure points.
  • @DaBoid

    "they told me to wait for an update"

    The update was release for iOS yesterday and will be available for PC soon, likely within a couple of days.
  • Hey, I got an entirely separate issue from all the of what I've seen here posted. I left this on the bad piggies update page, no one has responded yet, and I'm still affected by this. I also use a 4th gen iPod touch btw

    I am repeatedly having issues with this game. Since i 3 starred all the levels for the first two episodes, and completed 3 original sandboxes, everytime i try and move the pig while in the “building screen”, the app crashes. this also happens whenever i try to use tnt while in using the machines (which made the last few starboxes almost impossible to get in the last few sandboxes), and also when i cross finish lines, even in levels i’ve completed. what’s happening?? i hoped with this update something would change, and from the very first movement of the pig in level 1, to just crossing the finish line in the same level, i keep having to restart! what can i do?
  • @amslimfordy, "The update was release for iOS yesterday and will be available for PC soon, likely within a couple of days. "

    I saw that, thanks. I've been watching the version number on the Rovio download page, as well.
  • I tried the 6 rockets same color and direction but no achievement!!
    Is there a wait to get it?
  • I have a problem regarding the camera icon on Bad Piggies (iphone4s). The game takes the picture, but it doesn't appear in my camera roll or photo stream. Anyone know where it saves the picture to?
  • @nickthenoob are you sure you have allowed bad piggies to use your camera roll
  • I got the crash course achievement by using three blue rockets and three red rockets
  • Once when my dad was updating my computer I lost ALL my scores on Bad piggies Angry Birds and Angry Birds Space! And Angry Birds Rio and Angry Birds Seasons were gone!
  • @ilovebadpiggies That doesn't sound like a glitch or bug to me.
  • putting the plane part on top of another part will break it, same with the propeller part
  • @PJng exactly as @angryboy says. The laws of physics says that two objects cannot possess the same space.
  • how do you change bad piggies to use your camera because by acsidante i put dontuse the camera
  • Go to Settings --> Privacy --> Photos. You should then be able allow Bad Piggies to access Photos.
  • thank you !!!!
  • updated to flight in the night and the fun was suddenly over; as soon as i try to put the pig in a vehicle (level 1) BP crashes. i've tried maybe 10 combinations, and just once i succeded - with the pig in one particular seat. any workarounds/ solutions to this? i have an iphone5, but the same thing happened last week on my iphone4
  • @frdbrd -- You need an egg in the vehicle for flight in the night.
  • @mvnla2 - yes, i reserved a seat for the egg :-) but the app still crashes whenever i put a pig in the vehicle. are others experiencing the same bug/ problem?

    btw: if i delete the app and reinstall it, will my scores/ achievements disappear?
  • @AMslimfordy: Have you heard anything about Rovio's longer than usual delay in posting the PC Bad Piggies v1.1.0 update?
  • I haven't heard anything.
  • OK. Thanks for the update.
  • @bluegie & @DaBoid : Did the BP PC update fix your wireless problem?
This discussion has been closed. Please check the new forum.
← All Discussions
Post in the New Forum!