Bad Piggies Glitches & Bugs (Moved to the "New Forum"!)
  • the contraption is only able to collect a skull or star-box when the pig is touching the contraption or is in the contraption, is this a bug or just part of the game?
  • Regarding the activation issues PC I played in 1024*768 full screen but there was no problem for me. (i had activated in the non windowed mode)
    also in a level when the pig was hit directly by the TNT the pig just went through the wall
  • @angryboy This is part of the game. The same concept exists for crossing the finish line.

    @Abhijit This happens occasionally. It's an unfortunate side-effect of Box2D and similar programs.
  • Happens on androids,so,for example,you were given 3 wheels,or commonly rockets,after you use the given items and you play,and you restart it,the item somehow duplicates and already attached to the vehicle,and when you play it,it works,but a few second later,the game starts to lag and eventually freeze,happened frequently
  • I confirm CRASH COURSE and ADVENTURER achievement bugs.

  • I have been awarded 10 achievements thus far, but only 3 have unlocked (picture displayed) - the rest still have a ? beside them.
  • Some of the achievements have been slightly buggy for me, but seem to have "caught up" as it were. Verizon seems to have difficulty in the Pueblo, CO area for some reason.
  • I'm still having problems with achievements:
    1) GC says I have 15, but only 1 shows (Porcine Cannonball)
    2) Friday there were 14 showing; most disappeared Fri night. I got a new achievement Sat, and it hasn't shown up or corrected missing achievements. I'm not roaming the country, so can't blame location like truckdriver.
    OK, I closed absolutely everything that was open on my iPad; restarted GC and BPs; completed a level for good measure (OK, it was 1-1, but...), and used the internet, to prove that I am connected. Still just 1 achievement.
  • @mvnla2 I'm interested here. Can you provide me some more info?

    -- Find an achievement that you believe you are entitled to, but the image does not appear. Include the description of that achievement, word-for-word.
  • These are the ones I think are missing:
    Ground Hog Day -- Complete episode 1. I completed all the regular levels, but not all the blue ones. I am pretty sure I got it.
    Junior Wrecker -- Break off 1000 parts; I'm pretty sure I have this; and maybe Qualified Wrecker -- I think I'm going to have a hard time identifying missing achievements.
    Pigshaw -- Transport King Pig successfully 5 times
    Boom Boom I -- Blow up a total of 50 TNT cases
    Boom Boom II -- Blow up 500 -- Not sure about this one, but seems likely.
    Think Inside the... Place the pig in a wooden frame -- This sounds trivial?
    Think Outside the... Complete a level with the pig placed outside the transport.
    Literate Individual -- Check the credits
    Popper's Theory I --- Pop 100 balloons
    Tourist I -- Travel 1000 miles in a transport
    Brush with the past -- Discover remains of a failed explorer -- I assume this means find a skull
    Adventurer -- Discover 10 explorer remains in episode 1 -- I think I have all the skulls in 1
    Rolling Low I -- Should have if I got II, but don't know if it was counted
    Rolling Low 11 -- Roll 100 miles on the ground
    Wow! That's either 14 or 15, depending on if you count Rolling Low 1; so maybe I didn't get Qualified Wrecker?

  • Interesting. The whole Boolean expression is seems to be registering as 0.

    And you said that, at one time, you were indeed credited with these in GC?
  • @AMSlimfordy, on Fri I had 14, Sat. & today it thinks I have 15 (I got one yesterday, but not sure what -- maybe a skull one -- I never saw it in GC. It does still show Porcine Canonball, but only that one.
  • Very strange. Thanks for the info.
  • @AMslimfordy I have same problems (bugs) as @mvnla GC says I have 14 achievements (I completed 30 levels in GHD and 10 in WPF) and only Rolling Low II is listed. I play HD version on iPad use 3G and I am always online when playing. As I played achievements poped up but they are not listed in GC. I tried to sign out from GC, turn off device and sign in again but it didn't help.
  • The bug that I reported happens on my PC too
  • I reached level 2-27 and gathered 16 skulls when the entire game went blank and started over. At this time there is no way to back-up progress so now I must start over. Has this happened to anyone else?
  • @masmith52 You can follow our backup guide for Angry Birds. The file of interest is called "Progress.dat".
  • @mvnla2 @cosmo2503 Added to top layer. Sorry for the delay. Wanted a smooth internal link.
  • Slim, will you inform Rovio about these bugs?
  • Maybe these problems are device and/or related. The only achievement that is bugged on mine is crash course. I'm using an iPhone 5 on iOS 6.0. I'm still missing a few more achievements, but that's just because I haven't blown up enough stuff yet.
  • @Chriss already sent them the thread.

    @DanBarth Were Adverturer and Discoverer correct for you?
  • Got Discoverer as soon as I got my 11th skull. Never got Adventurer.
  • Progress, sort of? I now have 23 of 33 achievements, and woo hoo! I now have 2 showing in GC, Junior Wrecker and Porcine Cannonball. I sent e-mail to rovio, and tweeted Bad Piggies. No useful response yet.
  • I have the same problem as mvnla2 and cosmo. It is interesting that only a few of us have this problem, while others (including Slim) do not. I think it is because of the older system. I have iOS4.2 on my iPad. @mvnla2 - do you also have iOS4?
  • Slim, for you to see how this problen looks like, here are the links to the pictures of my achievements:
  • @annach @cosmo2503 I seem to have IOS 4.3.2
    Not sure if I can get IOS6?
  • @mvnla2 - thanks. This is it. Cosmo also has 4.3, see his message
    I was also worried at that time that Bad Piggies might require higher iOS. But it looks like the game works fine with iOS4, only connection with the Game Center seems to be broken.
  • I emailed rovio regarding my activation issue (PC version btw). They replied me a fews days later (I guess lots of people having the same problem?). They told me to enter the new code in lowercase. But when I pasted the code to the slot, the letters all turned into uppercase, and even if I typed in the code myself, they're still in uppercase.

    So I activated the game, then I tried playing 1-25, it showed "activate the full version to access this content" message. When I returned to the main screen, the activation icon was there again.

    Since I activated the game in screen resolution 1280 x 600 (I did "repair" the game before activation), so I tried activate the game again in 800 x 600, but it still didn't work. So I emailed them again and hopefully I will hear something soon. It's quite sad that I can't play the game when my brother is playing the game on his iPod touch...
  • @annach -- IOS 4.3 may be the reason, but I would think there would be a lot more than 3 people with the problem, if so. However, I am going to update to IOS6, but it is a time-consuming process.
    I have an iPad 2. First I had to update iTunes on my MacBook Air to 10.7(?? or current). That took most of 1 hr. Next I have to backup my iPad (haven't started); then can try to update to IOS6 on iPad through the MacBook Air. All of this is probably a good idea, but I don't have much hope that it will fix the GC problem. Will let you know.
  • @mvnla2 - ok, let me know how it goes. I have an old, first generation iPad, and it cannot be upgraded to iOS6. Hopefully, this problem with the Game Center will be fixed. If not, I think I will have to live with achievements not showing up. :)
  • @amslimfordy : Thanks for posting my workaround here. :)

    @bluegie : Did you check the box for "Windowed" mode when you tried 800x600?
  • @brave1966: Yes I did, as I saw your instruction at the top of this page. It didn't work for me though :(. I thought they would create an update for the PC version, since they said the problem had been successfully fixed in the email. I guess I will have to wait for their reply again.
  • @bluegie : Hmmmmmmmm..... They haven't released an update yet. The new video mode selector in BP seems to be causing much grief.
  • @AMSlimfordy -- I remember there was a lot of discussion about problems with IOS6 a few weeks ago, but don't remember where. Do you know where is it? Would like to read before I update.
  • It's just personal preference. Unless you indent to jailbreak, there's no harm in updating to iOS 6. The only shortcomings are the "Maps" app, the removal of the native "YouTube" app, and some complaints about battery life.
  • my IOS6 update went well, but if you plug it into the wall, it might go into recovery mode
  • on S-2 the hot-rod engine activated without me touching it or the button
  • @brave1966 -- Actually, now I think the video mode for BP may not be the main cause. I received an reply from rovio staff again, and they suggested me to use a wired connection to activate the game. So I tried , and it worked! I even tried playing the games in both 800 x 600 and 1280 x 600 modes, and the game worked out fine. But then, when I tried playing the game with wireless connection, the activation icon appeared again. And then I connected my laptop to wired connection again, and the icon disappeared. I retested a several times and came to a conclusion that the game connects to the server every single time to check for the validation, and somehow it can't connect with the server with wireless connection. My wireless is not super fast, but it's not slow either. I dun wanna go to my room and connect my laptop to wire just for the game. It's very inconvenient.

    Of course, this wired/wireless problem may applies to me only, since I dun really know the real cause for this.
  • @bluegie : Veeeeeeeeeeery strange. I'm on a wired connection.
  • @amslimfordy: Looks like @bluegie found another activation issue and workaround.
  • Stone glitch screenshot :
  • And when I play it, sometimes the screen turns to blue except the buttons
  • Oops, didn't notice that, sorry.How I do it:
    1. On S-4, place a tnt second from the right and the pig beside it
    2. The pig will hit two tnts and fly through the stone.
    About the second bug, I can only hear sounds. I go out from that level and back to that level. It works
  • Sounds like a RAM issue to me.
  • This sort of thing happens to me all the time. It works on any level. It especially works on springs and those bags that weigh you down. On the find the skulls level, you can place a tnt at the bottom four spaces from the left side. Then place a spring on top. Then put a tnt on top of the spring. Then skip a space up, and place another spring and then on top of that put a metal square with the pig inside. Something REALLY weird might happen.
  • I Got the adventure without the skulls
  • Can you give us some more details, Little Brother?
  • @amslimfordy it is over a week ago (infact it was october 28.) so I can't remember exactly what happened, but I think (about 80% sure) this was how it all happened.

    But first let us make this clear: According to Game Center:
    I have collected all the skulls today, but at the time I achieved the Adventurer and the Discoverer achievements I had not collected them all.

    I played the game, tried to get stars and looked for the skulls. I played both "Ground Hog Day" and "When Pigs Fly" and I know that I had under 10 skulls all together, because i had not unlocked the skull-sandbox yet (actually I had not unlocked any sandbox yet), when I took a break from the game (I use "The new iPad" so I can't remember if I closed the game completly, or just put it on standbye). A few hours later I started playing the game again. When it was done loading, there was a box down in the right corner of the main menu saying "Adventurer" with a badge next to the text. The moment that box dissapered, there was another box saying "Discoverer" with another badge next to it. Then I entered Game Center to see if it was two achivements I had achieved, and it was. When I read the achivements description, I saw that it was a mistake that I achieved them, but I was happy for getting them anyway. Now I am REALLY happy for getting them because others can't get them(not being rude. I hope that everybody will be able to get the achivements).

    @DanBarth has also written above that theese achivements aren't glitched for him to and he use iPhone 5 wich means it DOES NOT depend on your iDevice(s), but we both use iOS 6 so perhaps that is the key(but I seriously don't think so). And he has not answered your question yet AMslimfordy.

    If the other birds(or piggies) here in the nest can't get it, then I have probably just been very lucky. I think it is weird you can't get them, when i can.

    Crash Course availible in version 1.1.0 go to the Field of Dreams sandbox and build anything with six of the same coloured rockets. After a few minuttes you should get it!

    I really hope that Rovio will fix this issue, and everybody will be able to get the achivements, and i hope that it will be fixed it as quickly as possible!

    You can see my achivement list here:
    Ground Hog Day: Achieved.
    When Pigs Fly: Achieved.
    Well Grounded: Achieved.
    Born to be Airbourne: Achieved.
    Ground Breaker: Achieved.
    Pretty Fly: Achieved.
    Junior Wrecker: Achieved.
    Qualified Wrecker: Achieved.
    Veteran Wrecker: Not achieved.
    Pigshaw: Achieved.
    Hogffeur: Achieved.
    Complex Complex: Achieved.
    Skilled Pilot: Achieved.
    Boom Boom I: Achieved.
    Boom Boom II: Achieved.
    Boom Boom III: Achieved.
    Porcine Cannonball. Achieved.
    Think Inside the Box: Achieved.
    Think Outside the Box: Achieved.
    Literate Individual: Achieved.
    Popper's Theory I: Achieved.
    Popper's Theory II: Achieved.
    Popper's Theory III: Not achieved.
    Tourist I: Achieved.
    Tourist II: Achieved.
    Tourist III: Not achieved.
    Crash Course: Achieved.
    Brush with the Past: Achieved.
    Adventurer: Achieved.
    Discoverer: Achieved.
    Rolling Low I: Achieved.
    Rolling Low II: Achieved.
    Rolling Low III: Achieved.

    Pictures of the achievements here:

    I really hope, I helped you birds(or piggies)!
  • quoting Blugie: "I received an reply from rovio staff again, and they suggested me to use a wired connection to activate the game."

    I am seeing exactly the same thing. I downloaded the demo version of Bad Piggies, played it, liked it and bought an activation key. I could not activate the game. It would appear to activate, but then I would get an activation error when attempting the second episode (When Pigs Fly). After much back-and-forth, Rovio suggested I hard wire into my router. It worked! Activation was successful! When I removed the wire and went back to wifi, I was back to the demo version with the orange activate key icon and an activation error in the second episode.

    I have written back to Rovio several times and have no further suggestions except wait for the next update.

    Does anyone else have a solution to this problem?
This discussion has been closed. Please check the new forum.
← All Discussions
Post in the New Forum!